Topics

  1. Home
  2. Docs
  3. Topics
  4. FooEvents Check-ins App
  5. Connection issues

Connection issues

Having trouble connecting the FooEvents Check-ins apps to your store?

Common Issues:

  1. Was your URL entered correctly?
  2. Did you enter the correct username and password?
  3. Do you have the latest plugin installed?
  4. Does the WordPress user have appropriate permissions?
  5. Do you have any security plugins installed?
  6. Do you use a CAPTCHA plugin?
  7. Is REST API accessible?
  8. Is your site installed in a subdirectory of another WordPress site?

1. Was your URL entered correctly?

Ensure that your website URL is entered exactly as it appears in your web browser’s address bar.

  1. Did you specify the correct protocol (including http:// OR https://)?
  2. Does your website URL start with ‘www‘ or does it exclude ‘www‘?
  3. Does your website URL have a trailing slash at the end (/)?

You can find the exact URL that you need to enter in your WordPress admin area.
Go to Settings > General > WordPress Address (URL)

2. Did you enter the correct username and password?

The FooEvents Check-ins apps use the same WordPress username and password that you use to login to your website. Please ensure that you entered your username and password correctly and that you did not enter your FooEvents Account login details instead.

3. Do you have the latest plugin installed?

Check that you definitely have the latest version of the FooEvents for WooCommerce plugin installed on your website and the latest FooEvents Check-ins app installed on your device

4. Does the WordPress user have appropriate permissions?

By default, only users with the role of “Administrator” in WordPress will have access to the Check-ins app. This article explains how to assign roles to different WordPress users without necessarily giving them admin access to your website: User Roles, Capabilities and Permissions

5. Do you have any security plugins installed?

FooEvents uses an API to connect to your WordPress site. It is very possible that your security plugin is blocking API access to your site. To test if this is the case, temporarily disable any security related plugins such as Wordfence and iThemes Security to see if it is blocking access.

If your security plugin is blocking access to FooEvents, please try whitelisting the IP address of your tablet device.

6. Do you use a CAPTCHA plugin?

If you are using a CAPTCHA plugin, please ensure that CAPTCHA is not applied to WordPress logins.

If you are using the Advanced noCaptcha & invisible captcha Settings plugin, you can disable CAPTCHA on the login form via the plugins settings. Login to your WordPress admin area, go to Settings > Advanced noCaptcha & invisible captcha Settings > Enabled Forms > Login Form and ensure Login Form is not checked.

7. Is REST API accessible?

Make sure that your website’s REST API is accessible by entering the following address in your web browser: ‘www.yourwebsite.com/wp-json/fooevents/v1’

You should see a screen that displays code which starts with {"namespace":"fooevents\/v1","routes": as opposed to an error page such as 404 file not found which indicates that something is wrong with your server configuration or the REST API is blocked.

If you site is installed in the subfolder of another WordPress site, please proceed to section #8.

If the REST API is not accessible and the app tries to fallback to the less preferred XML-RPC connection, please check that your xmlrpc.php file is accessible. Enter ‘www.YOURSITE.com/xmlrpc.php’ in your web browser. You should see the following message if the xmlrpc.php file is accessible: “XML-RPC server accepts POST requests only.”

Please also contact your web host and ask them to do the following:

  • Whitelist the rule triggered by the IP address of your mobile device
  • Disable the Mod_security rule for your domain

8. Is your site installed in a subdirectory of another WordPress site?

If your site is installed in a subdirectory of another WordPress site, then the .htaccess files of your subdirectory might cause permalinks conflict making the REST API unaccessible.

Example:

  • Main WordPress ite https://www.example.com/
  • Your test WordPress site: https://www.example.com/testsite/

To solve this, you need to edit the .htaccess file in your subdirectory WordPress install. Replace the code inside your .htaccess file with the following code:

# BEGIN WordPress
RewriteEngine On
RewriteBase /your-subdirectory/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /subdirectory/index.php [L]
# END WordPress

Ensure that you replace /subdirectory/ with your own subdirectory name.

If you have tried all the troubleshooting steps above and you are still experiencing a connection issue, please contact FooEvents Technical Support and provide as much detail as possible so we can get back to you with other possible solutions.

Tags , , , , , , ,
Was this article helpful to you? Yes 1 No 1